Error: WordPress pre 태그 오류

이 코드를 pre태그에 넣으면 오류발생

link=expr "$ls" : '.*-> \(.*\)$'

정확히 어느 부분이 오류포인트인지 정확히 모르겠는데 워드프레스에서 일부 코드가 escape되서 문자열을 실행코드로 인식하는게 아닌가 싶다.

퍼블릭 글쓰기 권한이 있는 워드프레스에서 해당코드를 활용하면 서버단의 php를 실행시키는 공격이 가능하지 않을까