Tag Archives: VersionCrash

Error: Win10 Openjdk10 Gradle 빌드 오류

Could not determine Java version using executable C:\Users\Administrator\scoop\apps\openjdk\current\bin\java.exe.

openjdk10 환경에서 gradle 일정이하 버전은 안 돌아간다.
시스템 gradle은 4.9인데 프로젝트 gradle wrapper버전이 낮아서 openjdk10에서 구동이 안되는 상황

> gradle wrapper

실행해주면 해결

Error : SpringBoot Hibernate 버전충돌

SpringBoot 1.5.7에서 Hibernate 5.0.12 버전을 쓰는데

나는 Hibernate 버전 5.2.11을 사용

SpringBoot플러그인이 의존성을 지맘대로 들고와서 충돌을 일으킨다.

SpringBoot의 ext를 오버라이딩 해 줘야한다.

 

난 버전표시를 이렇게 쓰고 있는데

hibernate_version=5.2.11

스프링부트는 이렇게 쓰고 있다.

이걸 오버라이딩해야되니 한개 더 써준다.

hibernate.version=5.2.11